Issue is slowing down email processing
Incident Report for Fond
Resolved
This incident has been resolved.
Posted about 1 year ago. Aug 14, 2018 - 14:04 PDT
Investigating
We are currently investigating this issue.
Posted about 1 year ago. Aug 14, 2018 - 13:33 PDT
This incident affected: Platform Website.