Perks Digest email resent in error
Incident Report for Fond
Resolved
This issue has been resolved.
Posted over 1 year ago. May 10, 2018 - 12:30 PDT
Identified
We have identified the issue and are working on a fix.
Posted over 1 year ago. May 10, 2018 - 09:53 PDT
Investigating
The perks digest email scheduled for 5/3 was inadvertently sent again 5/10
Posted over 1 year ago. May 10, 2018 - 09:52 PDT
This incident affected: Email Delivery.