Some users are experiencing issues when attempting to confirm their account
Incident Report for Fond
Resolved
We are continuing to monitor this issue, but it is currently resolved.
Posted over 1 year ago. May 15, 2018 - 17:40 PDT
Investigating
We are currently investigating this issue
Posted over 1 year ago. May 15, 2018 - 13:52 PDT
This incident affected: Authentication Service and Email Delivery.