Intermittent failures when order certain egift cards

Incident Report for Fond

Resolved

Our eGift card fulfillment provider has fixed the issue.
Posted Dec 20, 2019 - 11:56 PST

Monitoring

Our gift card fulfillment service is experience issues completing orders for Walmart, Google Play and Lowes eGift Cards. We are investigating and will post updates here.
Posted Dec 20, 2019 - 08:43 PST
This incident affected: Store Service.